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Portable Document Format (PDF)  
Basic Testing Guide 

The testing guidance in this release is for Adobe Acrobat Pro DC (32-bit) Continuous Release | Version 
2024.002.20687. If the screens shown in the guide do not match your product interface, Adobe 
recommends visiting help for your current experience to identify the version in use.  Acrobat keyboard 
navigation shortcuts for current and previous releases can be found at Keyboard shortcuts for Adobe 
Acrobat. To enable single-key shortcuts, open the Preferences dialog box (Edit > Preferences), and 
under General > Basic Tools enable the Use single-key accelerators to access tools option. 

Figure 1 – Single-key shortcuts preferences  

 
Some tests can only be performed using a mouse or pointing device. Please refer to your assistive 
technology guide for quick navigation keys to help moving through the tag or contact structures if you 
are unable to use a mouse or other pointing device.  

Some tests in this guide require running the built-in Accessibility Check. For quick access to the 
accessibility tools used in this guide, add a shortcut to the Accessibility group in the Tools/Task pane. 
To create the shortcut, select the Tools tab > Protect & Standardize group > Accessibility > Add. The 
accessibility check is a system run check that requires manual/visual checks to verify: 

• The tag structure aligns with the content structure, logical reading order, and designated tab 
order.  

• Color contrast 
• Accuracy of alternative text, and  
• Link destinations 

Figure 2 – Tools/Task pane with the Accessibility group tools added for quick access 

 

https://helpx.adobe.com/acrobat/current/access-acrobat-across-web-mobile-desktop.html
https://helpx.adobe.com/acrobat/current/keyboard-shortcuts.html
https://helpx.adobe.com/acrobat/current/keyboard-shortcuts.html
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Preconditions 
A. Is the PDF a PDF Portfolio or does the PDF have file attachments? 

How to test A 

PDF Portfolio 
A PDF Portfolio is a collection of folders and files assembled into an integrated PDF unit. The files in a 
portfolio may originate from many different applications, will retain their original format, can be 
previewed in Acrobat Pro, and will open in the source software, if available on the local system.   

Figure 3 – Sample PDF Portfolio containing folder and files in various formats, displaying preview for .html file.  

 
Instruction A.1: Open each individual document/file included in the portfolio and test with the 
corresponding test process for that file format. 

Test A.1: Was each file tested with the corresponding test process, and did the file pass? If not, the PDF 
Portfolio fails this test. 

PDF Attachments 
PDF Attachments are files saved within the PDF that are related/relevant to the PDF’s main content. 
Attachments may be in various formats.  

Instruction A.2: Open the PDF and activate the View menu > Show/Hide > Navigation Panes > 
Attachments. Select and open each attachment separately and test with the corresponding test 
process. 

Figure 4: PDF Attachments pane containing multiple file attachments 

 
Test A.2: Were all attachments tested with the corresponding test process, and did they pass? If not, 
the PDF fails this test.  
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B. Was the PDF generated from Adobe Designer or LiveCycle Designer? 
PDF fillable forms authored with Adobe LifeCycle Designer, or Designer cannot be tested or 
remediated for accessibility with Acrobat Pro. By default, all Designer PDF Forms are edit protected.  

How to test B 

Instruction B: Open the File menu > Properties > Document Properties and select the Description 
tab (or Ctrl+D). 

Figure 5: Document Properties Description tab indicating Adobe LiveCycle Designer / Designer as producing application 

 
Test B: Do the properties for Application: and PDF Producer: display Adobe LiveCycle Designer or 
Designer? If so, the form cannot be tested using Acrobat Pro.  

C. Does the PDF contain programming scripts?  
Adding programming (Scripts) to a document turns it into a software application. Applications should 
be tested using software testing methods. The Department of Homeland Security’s (DHS) Section 508 
Trusted Tester Conformance Test Process provides a code-inspection based test approach.  

How to test C 

Instruction C: Activate the Accessibility Checker (Tools > Accessibility > Add > Accessibility Check > 
Start Checking). Expand the Page Content category to view issues. 

Figure 6: Scripts – Needs manual check accessibility check results 

 
Test C: Does Scripts – Needs manual check display under the Page Content category? If so, you must 
test the PDF with the DHS’s Section 508 Trusted Tester Conformance Test Process. 

https://www.dhs.gov/trusted-tester
https://www.dhs.gov/trusted-tester
https://www.dhs.gov/trusted-tester
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D. Is the PDF tagged? 
Documents must be tagged to be accessible to assistive technology users.  

How to test D 

Instruction D: Activate the File menu > Properties > Description tab to open the Document 
Properties window. 

Figure 7: Document Properties showing Tagged PDF: Yes 

 
Test D: Does Tagged PDF display Yes under the Advanced section in the Document Properties > 
Description tab? If not, the PDF fails this test. 

E. Is the PDF made up of images, scanned pages or does it contain 
scanned or images of text pages? 

How to test E 

All or part of a PDF may contain pages that are made up of an image, or that may have been scanned 
into a PDF. Images of text, or scanned pages content is not apparent to assistive technology users. 
Optical character recognition (OCR) software will extract text from a scanned paper document or 
image file, and convert it to editable text, that can be tagged and made accessible for assistive 
technology users. 
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Note: While testing with Acrobat, you must uncheck the options under Edit > Preferences > 
Accessibility > Other Accessibility Options to receive alerts for scanned/image only pages. In the 
Scanned Page Alert window DO NOT check Do not show this message again.  

Figure 8: Other Accessibility Options preferences 

 
Instruction E.1: Scanned Page Alert displays when you open the PDF. 

Figure 9: Scanned Page Alert window 

 
Test E.1: Does the PDF display a Scanned Page Alert when opened? If yes, the PDF fails this test. 

Instruction E.2: Activate the Accessibility Check (Tools > Accessibility > Accessibility Check > set the 
category to Documents > Start Checking). Expand the Document testing results. 

Figure 10 - Failed accessibility check results for image only PDF 

 
Test E.2: Does the Accessibility Checker flag Image-only PDF – Failed as an issue? If yes, the PDF fails 
this test. 
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Instruction E.3: The PDF may contain scanned pages or inserted pages that are untagged. Activate the 
Accessibility Check (Tools > Accessibility Check > Documents > Start Checking). Expand the 
Document category in the Accessibility Checker pane to display issues.  

Figure 11: Failed accessibility check results for tagged PDF 

 
Test E.3: Does Tagged PDF – Failed display under the Document category? If yes, the PDF fails this 
test 

F. Does the PDF include tracked changes or have added notes/comments? 
PDFs may contain tracked changes markups and notes/comments either imported from the source 
document or added directly in the PDF.  

Tracked changes markups from source documents, except comments, will not convert to PDF using 
the Save as PDF feature. All tracked changes are accepted as final and comments are converted to 
untagged annotations that must be manually tagged and added to the tag structure. 

Figure 12 - No visible tracked changes in Save as PDF output - Notes are untagged annotations 

 
Exporting to a PDF/XPS file retains the visual appearance of the tracked changes. All text is converted 
to tagged content, including notes/comments. Changes will display visually but the tagged content 
includes deletions, insertions, moved and other text changes making the tagged content 
unintelligible. Notes/comments are tagged as Annotation, strikethrough, underlines for insertions, 
moves, etc. may be tagged as figures or paths.  
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Tracked changes markups added with Acrobat Pro must be explained in the associated markup’s 
comment window, so assistive technology users may have a logical explanation of what was deleted, 
added, moved, or changed. 

How to test F 

Instruction F.1: To check for untagged annotations (notes/comments) in a tracked changes PDF, 
activate the Accessibility Check (Tools > Accessibility Check > Documents > Start Checking). 
Expand the Page Content category in the Accessibility Checker pane to display issues.  

Figure 13: Accessibility Checker result for Tagged annotations – Failed  

 
Test F.1: Does Tagged annotations - Failed display under the Page Content category? If yes, the PDF 
fails this test. 

Instruction F.2: A PDF that has visual track changes originating from a source document (PDF/XPS 
export) is not accessible to assistive technology users.  

Figure 14: PDF/XPS export tracked changes 

 
Test F.2: Does the PDF have visible tracked changes, and is the tagged content inarticulate? If yes, the 
PDF fails this test 
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Instruction F.3: PDF text markups must have comments explaining the action and content change. To 
check markup comments, have accurate descriptions for the action and content change go to Tools 
menu> Share & Review section > Comment > Open to access the Comments pane. Verify the 
comments for each tracked change have an account of the action and what content is affected 
verbatim.  

Figure 15: Tracked changes in PDF with comments reflecting the action and affected text 

 
Test F.3: Do all comments associated with the track changes reflect the action and content change? If 
not, the PDF fails this test.  
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Document Properties 
1. Does the PDF display a descriptive title when opened? 

How to test 1 

A descriptive title identifies the document or its purpose and helps users identify and find documents.  

Instruction 1.1: Go to the Description tab in the Document Properties window (File > Properties > 
Description). 

Figure 16: Title field in the Document Properties with a descriptive title 

 
Test 1.1: Does the Title field have a descriptive title identifying the document? If not, the PDF fails this 
test. 

Instruction 1.2: Accessibility Check will automatically fail Document > Title if the initial view is set to 
display File Name. Go to File > Properties > Initial View tab and verify Window Options is set to 
Show: Document Title. 

Figure 17: Initial View set to Show: Document Title 

 
Test 1.2: Does the Initial View tab display Document Title in the Window Options > Show: field? If 
not, the PDF fails this test.  
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2. Is Assistive Technology access enabled? 

How to test 2 

Security settings are useful to safeguard the integrity and unauthorized manipulation of documents. 
However, these settings may also block access to assistive technology users, unless the Content 
copying for Accessibility option in the Document Properties > Security tab is enabled.  

Instruction 2: Go to File > Properties to open the Document Properties > Security tab and verify the 
Content Copying for Accessibility option is set to Allowed. 

Test 2: Does Content Copying for Accessibility display Allowed? If not, the PDF fails this test. 

Figure 18: Document Restrictions Summary with Content Copying for Accessibility enabled 

 

3. Is the appropriate language assigned? 

How to test 3 

Document Language 
Languages other than the system defined default language in PDFs must be identified under the 
Document Properties > Advanced tab > Language option. 

Note: If the language is not available from the drop-down menu, you can type it in the language field 

Instruction 3.1: Go to File > Properties > Document Properties > Advanced tab > Reading Options > 
Language and verify the PDF language is set to the corresponding document language. 
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Figure 19: Document Properties for Language Reading Options set to Greek 

 
Test 3.1: Does the Language field under the Document Properties > Advanced tab display the 
corresponding document language? If not, the PDF fails this test. 

Sections that contain text in languages other than the default document language 
When the language of a paragraph, or part of a paragraph, differs from the document language, we 
must identify that language so screen reader users can hear the information pronounced correctly. 

Instruction 3.2: Identify any sections in the document where the content text differs from the default 
document language. Exclude proper names/titles, technical terms, or commonly used foreign words. 
Select the text in the language that differs from the document language. Open the Accessibility Tags 
pane (View > Show/Hide > Navigation Panes > Accessibility Tags). Find and select the corresponding 
tag (Accessibility tags pane > Options menu > Find Tag from Selection). With the tag selected, open 
the Object Properties window (Alt + Enter > Content tab > Language). 

Test 3.2: Does the Language field display the selection’s language or a letter code for the 
representation of the language name? If not, the PDF fails the test. 

Figure 20 - Examples of Polish identified as language in Tag Properties using full name or two letter code (pl) 

 

http://www.loc.gov/standards/iso639-2/php/English_list.php
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Accessibility Tags 
4. Do the accessibility tags follow the visual/logical reading order of the 

document? 

How to test 4 

Assistive technology users rely on tags to identify and access the document’s content. All meaningful 
content must correspond to a tag, and the order of the tags must follow the logical or visual layout of 
the document. 

Note: This is a manual check that requires the use of the Accessibility tags pane and the Reading 
Order pane or the use of assistive technology to read through the document content.  

Figure 21: Path to Accessibility Tags pane using the View menu 

  
Instruction 4: Open the Accessibility tags pane (View menu > Show/Hide > Navigation Panes > 
Accessibility tags). Expand the Accessibility tags Options menu and select the Highlight Content 
option. Reopen the Accessibility tags Options menu and select the Reading Order option or type x to 
open the Reading Order pane. In the Reading Order pane enable the Show page content groups 
checkbox and select the Page content order radio button. In the Accessibility tags pane, expand the 
Tags tree to show all tags. Use the keyboard’s down arrow key to navigate through the tags. Verify all 
meaningful content on the page is enclosed in a content structure container, and that the selected tag 
in the Tags tree corresponds to the highlighted numbered reading order in the document content.  
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Figure 22 - Accessibility tags Options menu with Highlight Content enabled and Reading Order pane open  

 
Figure 23 – Tag order in the Accessibility tags tree matches reading order of page content  

 
Test 4: Do all accessibility tags correspond to the numbered reading order of the document content? If 
not, the PDF fails this test. 

5. Is all decorative content marked as an artifact? 

How to test 5 

Decorative content, such as ornamental, trivial, or redundant objects, images, and text, must be 
marked as artifact so that it can be ignored/skipped by assistive technology users.  

Instruction 5: Open the Accessibility tags pane (View menu > Show/Hide > Navigation Panes > 
Accessibility tags). Expand the Accessibility tags Options menu and select Find… to open the Find 
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Element window. Select Artifacts in the Find: field, enable Search Page, or Search Document radio 
button. Select Find > Find Next to highlight and move through all artifacted elements in the 
document. 

Figure 24: Path to finding Artifacts in a PDF 

 
Test: Is all ornamental, trivial, or redundant content and objects marked/identified as artifacts? If not, 
the PDF fails the test. 

6. Is vital information in headers, footers, and watermarks tagged? 

How to test 6 

Vital information in the source document’s header or footer, and watermarks (Respond by X Date, 
CONFIDENTIAL, or Do Not Distribute, etc.) will not be converted to tagged content in a PDF. To ensure 
the vital information is discoverable by assistive technology users, the untagged vital content must be 
manually tagged, and placed first in the reading order of the tag tree, or at the beginning of the related 
section.  

Note: this test is not necessary, if the content in the headers and footers is redundant, repeated, or 
decorative (i.e., page numbers, running headers or footers) 

Instruction 6: Locate vital information at the beginning of the document or a section, at the top or 
bottom of a page, or in the form of a watermark. In the Accessibility tags pane (View menu > 
Show/Hide > Navigation Panes > Accessibility tags). Expand the Accessibility tags Options menu 
and select the Highlight Content option. Highlight the vital information and expand the Accessibility 
tags Options menu and select Find Tag from Selection. 
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Figure 25: Example of vital information in a footer tagged and placed at the top of the tag tree 

 
Test 6: Is the vital information in the header, footer and/or watermark tagged, and placed at the 
beginning of the tag tree, or the related section? If not, the PDF fails this test. 

7. Are all headings in the document tagged with heading tags? 

How to test 7 

Assistive technology users will not have the ability to easily find and navigate content from text that 
only visually appears to be a heading (bold, large text, underline, etc.). All headings must be tagged 
with a heading tag (<H1>, <H2>, <H3>, <H4>, <H5> or <H6>). 

Note 1: All headings in source documents must be programmatically identified with an assigned 
heading level, either by using heading styles or mapping to a standard heading tag.  

Note 2: Most short documents (1 to 2 pages) may not contain headings, and these tests may not apply.  

Instruction 7.1: Open the Accessibility tags pane (View menu > Show/Hide > Navigation Panes > 
Accessibility tags). In the Accessibility tags pane, expand the Tags tree to show all tags. Check the 
tag tree for heading tags. If the tag tree doesn’t have heading tags, check the content for any text that 
visually appears to be a heading (bold, large text, underline, etc.), and select the text. Expand the 
Accessibility tags Options menu and select Find Tag from Selection. The selected tag should have a 
heading tag (H1 through H6).  
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Figure 26: Heading tagged as text (paragraph)  

 
Test 7.1: Are all visually apparent headings in the document tagged with a corresponding H1 through 
H6 tag? If not, the PDF fails the test. 

Instruction 7.2: Locate any nonstandard PDF heading tags (e.g. <Title>, <H_1>, <Section>; 
<Heading3>). Check the appropriate mapping, by opening the Role Map (Accessibility tags > Options 
menu > Edit Role Map). In the Role Map window expand Document Roles to check mappings 
correspond to a standard heading tag. 

Figure 27: Role Map Pane 
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Test 7.2: Are all non-standard heading tags mapped to a standard heading tag? If not, the PDF fails the 
test. 

Instruction 7.3: Open the Accessibility tags pane (View menu > Show/Hide > Navigation Panes > 
Accessibility tags). Check all heading tags in the document are in logical sequence without skipping a 
level.  

Note: You could also run the Accessibility Check (Tools > Accessibility > Open > Accessibility Check 
> Start Checking). The Headings section will display: Appropriate nesting – Failed if headings are 
tagged out of sequence.  

Figure 28: Incorrectly nested heading sequence 

 
Test 7.3: Are all the headings in the document nested in a logical sequence (<H1>, <H2>, <H3>; <H1>; 
<H1>, <H2>)? If not, the document fails this test.  

8. Are lists tagged correctly? 

How to test 8 

Lists help organize and structure content. Assistive technology users cannot infer meaning from lists 
created using only tabs, a dash, or manual numbering. To create the appropriate structure tags for 
lists in PDF that are accessible to assistive technology users, the lists must be programmatically 
identified using built-in styles/settings for lists in the source documents. All lists must have a parent 
List (L) tag, with a nested child List Item (LI) tag. All LI tags must have a nested child Label (Lbl) tag 
and a child List Item Body (LBody) tag. Multi-level lists must be nested in the last LBody tag of the 
preceding level.  

Note: Lists originating in Microsoft Word will not export a Label (Lbl) tag. The List Item Body (LBody) 
tag includes the bullet or number pertaining to that List Item.  

Instruction 8.1: Open the Accessibility tags pane (View > Show/Hide > Navigation Panes > 
Accessibility tags). Locate bulleted, or numbered lists in the page content. Highlight the list and find 
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its corresponding tag (Accessibility tags Options menu > Find Tag from Selection). Expand the list 
tag (activate the triangle next to the <L> tag). 

Test 8.1: Does the highlighted content have a parent <L> tag, with nested child List Item (LI) tag(s), 
and do all child <LI> tags have nested <Lbl> and/or <LBody> child tags? If not, the PDF fails this test.  

Figure 29: Example of correct tag structure in the tag tree 

 
Instruction 8.2: Open the Accessibility tags pane (View > Show/Hide > Navigation Panes > 
Accessibility tags). Locate any multilevel lists in the content document. Highlight the second list level 
content and find its corresponding tag (Accessibility tags Options menu > Find Tag from Selection).  

Figure 30 -Examples of tag structure for multilevel lists 

 
Test 8.2: Are the tiered multilevel lists nested in the last LBody tag of the preceding level? If not, PDF 
fails this test. 
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Objects 
9. Do all meaningful images and objects in the PDF have a description of 

their purpose or function? 

How to test 9 

Images, Objects, Shapes, Charts, etc. allow authors to provide meaningful information in a visual 
format. Assistive technology users cannot infer meaning from selecting the illustration alone. To 
provide assistive technology users comparable access to the purpose or meaning of graphic content a 
contextual description in the form of a caption, nearby text, or Alternate Text is required. 

Note 1: Images of, or that contain text (i.e. logos, agency seals) should have the text that is part of the 
image included in the alternate or descriptive text. 

Note2: Complex Images, charts, graphs, etc. may require a longer description. These types of 
descriptions are usually part of the tagged content or offered as a caption and require no test in PDF. 
Images/Objects associated with longer descriptions may have been artifacted to avoid redundant 
alternate text.  

Instruction 9: Activate the Accessibility Check (Tools > Accessibility Check > Documents > Start 
Checking). Expand the Alternate text category in the Accessibility Checker pane to display issues. 

Figure 31: Accessibility Check Alternate Text - Failed testing results 

 
Test 9: Does the Alternate text group display Passed results for all listed categories? If not, the PDF 
fails this test.  

10. Does the PDF have data tables? 

How to test 10 

Data tables in PDFs must be tagged as <Table>. Table rows must be tagged as Table Row <TR>, 
column and row header cells must be tagged as Table Header Cell (TH), and data cells must be 
tagged as Table Data Cell (TD). Tables containing multiple header rows, or cells that span multiple 
rows or columns are complex tables and must have data / header associations to be accessible.  
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Note: the table editor is a visual tool that is not keyboard accessible. To verify/test the correct reading 
order of a complex table, assistive technology users must use the Accessibility tags pane to tab 
and/arrow through the table tags. Assistive technology users may skip the tests in Section 10.  

Instruction 10.1: Locate programmatically identified data tables. Open the Accessibility tags pane 
(View > Show/Hide > Navigation Panes > Accessibility tags) and select the first table in the tag tree. 
Expand the Accessibility tags Options menu and type the letter q to open the table editor and verify 
the table header cells are tagged as table headers.  

Figure 32: Table editor displaying table cell properties 

 
Test 10.1: Are the table header cells tagged as <TH> and the data cells as <TD>? If not, the PDF fails 
this test. 

Complex tables (tables with multiple header rows/columns, split or merged cells) require Header Cell 
IDs to create associations with related header/data cells providing assistive technology users accurate 
reading order of the table data.  

Instruction 10.2: Open the Accessibility tags pane (View > Show/Hide > Navigation Panes > 
Accessibility tags) and select the first table in the tag tree. Expand the Accessibility tags Options 
menu and type the letter q to open the table editor. Select a <TH> cell in the document content 
window, right click to open the table editor options, and select Table Cell Properties…(P). For each 
table header cell verify:  

1. Header Cell radio button is checked 
2. Scope indicates Column or Row 
3. Attributes field for Row Span and Column Span are correct 
4. ID: field has a unique identifier 
5. If applicable, Associated Header Cell IDs are listed 

Note:  If the cell tags identifiers (TH, TD) do not display, check the Show table cells options in the 
Reading Order Pane, or under the Table Editor Options… section in the table editor options pop-up 
window.  

Figure 33:Table Editor options window 
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Test 10.2: Does the header cell scope, row, and column span match the visual layout of the table, and 
do header cells display a unique identifier under the ID: field? If not, the PDF fails this test. 

Figure 34: Example of cell properties options for a table header cell for a complex table  

 
Instruction 10.3: Complex tables require an additional test to verify table data cells and table header 
cells are associated (linked) to ensure the data reads correctly for assistive technology users.  

Open the Accessibility tags pane (View > Show/Hide > Navigation Panes > Accessibility tags) and 
select the first table in the tag tree. Expand the Accessibility tags Options menu and type the letter q 
to open the table editor. Select a <TD> cell in the document content window, right click to open the 
table editor options, and select Table Cell Properties…(P). For each data cell verify: 

1. Data Cell radio button is checked 
2. Attributes field for Row Span and Column Span are correct 
3. Associated Header Cell IDs: for row and column headers are listed 

Figure 35: Table cell properties for a data cell 
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Figure 36: Example of data cell associations with header cells in table cell properties 

 
Test D: Are Data Cells associated with Header Cell IDs (Figure 29)? If not, the PDF fails this test. 

11. Does the PDF have links and controls? 

How to test 11 

Links and controls must: 

1. Be uniquely identified 
2. Describe the destination, function, and/or purpose in the name or within context 
3. Be in a tab order that matches the visual/logical order of interactive elements (links, controls, 

and form fields) 

Instruction 11: Press the Tab key to navigate to links and user controls in the content. Check that each 
identified link has an unambiguous name that describes its destination, function, and/or purpose OR 
that it is determinable within context. For images that are a link or user control, the alt-text may 
contain the link purpose, function, or destination. 

Table 1: Link examples 

Uniquely identified Link: …further guidance is available on www.section508.gov 

Links Determinable within Context: Additional guidance is available in the AED COP best practices library. 

Ambiguous Links Not Determinable 
Within Context: Click here / Click here for information about each topic. 

Test 11: Does the link have a unique name that describes the destination, function, and/or purpose 
OR that is determinable within context? If not, the PDF fails this test. 

12. Is the PDF a fillable form? 

How to test 12 

To complete a form using assistive technology, it is necessary to provide instruction, directions, and 
cues allowing the assistive technology user to enter information correctly and accurately in the 
designated fields.  

http://www.section508.gov/
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Instruction 12.1: All form fields must have a tooltip, and the tool tip must match its label or 
instruction.  

Figure 37: Example of a fillable form, tooltip showing over a selected field 

 
Test 12.1: When you tab through or hover over each form field, is a tooltip revealed and does the 
tooltip/instruction correspond to the label? If not, the PDF fails this test. 

Instruction 12.2: Press the tab key to find form fields (text fields, radio buttons, checkboxes, combo 
boxes, etc.). The tab order must correspond to the visually logical order of the form fields.  

Test 12.2: When you tab through the PDF, does the tab order match the visually logical order of the 
form fields? If not, the PDF fails this test. 

13. Does meaningful information conveyed only with color or other 
visual characteristics also have a text description?  

How to test 13 

Using only color or other visual characteristics (shape, size, page location, etc.) to convey meaning will 
not provide comparable access to people who are blind, have low vision, or are colorblind. 

Instruction 13: Find where color and/or other visual characteristics, such as green square in right 
corner of the screen, large yellow rectangle, bottom center of the page, etc., are used to convey 
meaning.  

Table 2: Example of project status table using only color to convey project status – Failed condition 

Project Status 

Project A  
Project B  
Project C  

Table 3: Example of project status table using color with text description to convey project status – Passing condition 

Project Status 

Project A Green - On Time 

Project B Yellow - At Risk 

Project C Red - Late 

Test 13: Is there text that conveys the meaning of the color or other visual characteristics? If not, the 
document fails this test. 
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14. Is the contrast ratio between text and background sufficient? 
Note: This test is not necessary, if the document text is black on white background (or close to it). This 
test requires the Colour Contrast Analyser (an external application) to get accurate ratio numbers. The 
Accessibility pane (Keyboard navigation). 

How to test 14 

Instruction 14: Open the Colour Contrast Analyser application. Drag the Foreground eyedropper icon 
over a sample of the text or image of text. Drag the Background eyedropper icon over a sample of the 
background color. 

Figure 38: Examples of pass and fail results with the Colour Contrast Analyser 

 
Test 14: Does color contrast ratio of Foreground (text) and Background ratio meet the minimum 
contrast ratio (4.5:1)? If not, the document fails this test. 

Note: To check for color blindness simulation with any preview in the testing window, open the View 
menu and select the Colour Blindness simulation (Ctrl+B) option.  

Figure 39: Colour Contrast Analyser color blindness simulation samples 

 

https://www.paciellogroup.com/resources/contrastanalyser
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Miscellaneous 
15. Does the PDF contain audio-only, video-only, or multimedia objects 

that contain meaningful information? 

How to test 15 

PDFs that contain audio, video, or multimedia files must have additional information so individuals 
with disabilities have comparable access to the information. 

Table 4: Additional information required for video-only or multimedia files embedded in PDFs 

Type Also include: What is this? 

Video-only Accurate and complete text 
description 

A description is a text version of what is being shown 
in a video-only file. 

Multimedia (audio 
and video) 

Accurate, complete, and 
synchronized captions and audio 

descriptions 

Captions are time-synchronized text version of 
exactly what is being said and/or a description of the 

relevant sounds in the multimedia file. Audio 
descriptions are time- synchronized descriptions of 

what is being shown in the multimedia file. 

Note: If the PDF does not contain audio, video, or multimedia files, you do not need to perform this 
test.  

Instruction 15: Activate the meaningful audio-only object 

Test 15.1: Does the audio-only object have transcript that is accurate and complete? If not, the PDF 
fails this test. 

Test 15.2: Does the video-only object have text description that is accurate and complete? If not, the 
PDF fails this test. 

Test 15.3: Does the multimedia (audio and video) have synchronized captions and audio description 
that are accurate and complete? If not, the PDF fails this test. 

16. Does the PDF have flashing objects? 

How to test 16 

Federal agencies do not typically see flashing objects embedded into documents. Since flashing 
objects may be a public safety issue for individuals with photosensitive epilepsy and there is not 
typically a compelling business need, flashing objects should be excluded. If you feel you do have a 
compelling business need, please contact your agency’s Accessibility Team for assistance in ensuring 
your object flashes below 3Hz. 

17. Does the PDF need an accessible alternate version? 

How to test 17 

Federal agencies have the goal to produce one accessible document for everyone. However, there may 
be times when this is not feasible. Therefore, it is recommended that you contact your agency’s 
Accessibility Team to ensure an alternate version is necessary, since you are still required to create an 
alternate version that is accessible, up-to-date and has equivalent content. 
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